
A.	 Complete the following statements.

	 1.	 A tablet PC is a _______________________________________________________________

			   ___________________________________________________________________________.

	 2.	 Smartphones can run various applications ________________________________________

			   ___________________________________________________________________________.

	 3.	 An embedded system is a ______________________________________________________

			   ___________________________________________________________________________.

	 4.	 Third generation language (3GL) is a _____________________________________________

			   ___________________________________________________________________________.

	 5.	 Assembler translates __________________________________________________________

			   ___________________________________________________________________________.

B.	 Write True or False.

	 1.	 We can carry a desktop computer anywhere easily.

	 2.	 Some palmtops use a pen as an input device instead of keyboard.

	 3.	 A game console gives a video signal or visual image as an output further displaying a video 
game that the user can play.

	 4.	 System Z10 is an example of supercomputer.

	 5.	 An assembly language needs an extra program called assembler to translate the program 
into a machine language.

C.	 Name the following.
	 1.	 A computer known as notebook computer
	 2.	 An example of minicomputer
	 3.	 A language which is very fast and is executed directly by the CPU
	 4.	 A language used primarily by the scientific community to solve scientific and mathematical 

problems
	 5.	 A program used to convert the object program into an executable program

D.	 Answer the following questions.
	 1.	 How is a laptop different from a palmtop?
	 2.	 Differentiate between smartphone and game console.
	 3.	 Differentiate between microcomputers and minicomputers.
	 4.	 What are the advantages and disadvantages of machine language?
	 5.	 Explain some examples of third generation language.
	 6.	 Discuss some types of fourth generation languages.
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Answers to Worksheet

A.	 1.	 A tablet PC is a notebook or a slate-shaped mobile computer having a touch screen that allows 
a user to operate it without a keyboard and a mouse.

	 2.	 Smartphones can run various applications called apps providing a wide range of functions 
from word processing to gaming and translating languages.

	 3.	 An embedded system is a combination of hardware and software where the software called 
the firmware is embedded into the hardware.

	 4.	 Third generation language (3GL) is a programming language that is simple to learn, write and 
understand.

	 5.	 Assembler translates the assembly language code which are called mnemonic code (source 
program) into machine language code (object program).

B.	 1.	 False	 2.	 True	 3.	 True	 4.	 False	 5.	 True
C.	 1.	 Laptop
	 2.	 PDP-8
	 3.	 Machine language
	 4.	 FORmulaTRANslation (FORTRAN)
	 5.	 Linker program
D.	 1.	 Laptop: A laptop is smaller than a desktop computer. It is so small that we can keep it on our 

lap and work. It is also known as notebook computer. We can carry it easily to any place. It also 
works on battery. Nowadays, laptops are commonly used computers.

		  Tablet PC: A tablet PC is a notebook or a slate-shaped mobile computer. It has a touch screen 
that allows a user to operate it without a keyboard and a mouse.

	 2.	 Smartphone: A smartphone is a handheld device consisting of features of both personal 
computer and mobile phone. It allows the user to make and receive phone calls and text 
messages, click and store images, make videos, browse the Internet, send and receive 
e-mails, dictate voice and take notes, and access utilities like Ebook Reader and Calculator. 
Smartphones can run various applications called apps providing a wide range of functions 
from word processing to gaming and translating languages.

		  Game Console: A game console is a computer device that gives a video signal or visual 
image as an output further displaying a video game that the user can play. The user can play 
interactive video games using game console. The device can be connected to a television or 
a computer. In this case, the interaction of the user with the game occurs through a handheld 
computer. Xbox, PlayStation 3 and Wii are some examples of game consoles.

	 3.	 Microcomputers

•	 They are the most commonly used computers.

•	 They are small in size and cost less.

•	 They are also known as Personal Computers (PCs).

•	 They are generally used in places such as schools, offices, shops and homes. Desktop 
computer, laptop, tablet PC, palmtop, handheld devices like smartphone and game 
console, and embedded systems are examples of microcomputers.



		  Minicomputers

•	 They are bigger than microcomputers.

•	 They are more powerful than microcomputers.

•	 They are faster and have more memory.

•	 They are used in offices to connect many computers together and support 4 to 200 users 
at the same time.

•	 HP 2100, MicroVAX 3100 and PDP-8 are some examples of minicomputers.
	 4.	 First generation language (1GL) is essentially a machine language. Instructions are given in 

machine codes, i.e., in the form of a long string of 0s and 1s.
		  Advantages of Machine Language

•	 It is very fast as it is executed directly by the CPU.

•	 There is no need for translation.
		  Disadvantages of Machine Language

•	 The simplest of instructions need lengthy coding and programming.

•	 The programming is tedious and error-prone.

•	 Each processor has its own machine code.

•	 Programs written for one machine do not work on a different or newer model.
	 5.	 Some examples of high-level languages are explained below.

•	 FORmulaTRANslation (FORTRAN): It is a language used primarily by the scientific 
community to solve scientific and mathematical problems.

•	 Common Business Oriented Language (COBOL): It is a language that has gained immense 
popularity in commercial establishments.

	 6.	 Some common types of 4GLs are listed below.

•	 Database Query Languages: Structured Query Language (SQL), NATURAL

•	 Report Generators: Report Builder, Oracle Reports

•	 Rapid Application Development Tools: Power Builder, Oracle Forms

•	 Table Driven Codeless Programming: eDeveloper

•	 GUI/Web Development Tools: Cold Fusion
	 7.	 A program written in any other language needs to be converted into machine language 

which the computer can understand. The software used to convert a high level language into 
machine language is called a language processor or a language translator.

	 8.	 Assembler: Assembler translates the assembly language code which are called mnemonic 
code (source program) into machine language code (object program). After assembling, a 
linker program is used to convert the object program into an executable program. Assemblers 
are used mainly in the development of system software.

		  Interpreter: Instructions of a high-level language are coded in many statements. At the 
time of their execution, they are converted statement by statement into machine code by 
using a system software called interpreter. There are certain disadvantages of interpreters. 
As instructions are translated and executed simultaneously using interpreters, they are very 
slow for executing large programs. Hence, interpreters are not suitable for most application 
developments.



Chapter 2: File Management – Organisation of Data

A.	 Fill in the blanks.

	 1.	 A _______________ stores and organises relevant computer files together.

	 2.	 _______________ a file/folder means moving it from original location to another location.

	 3.	 The sorting option _______________ groups the files on the basis of their type.

	 4.	 A _______________ is a standard way used to encode information in a computer file indicated 
by the file’s extension.

	 5.	 MS PowerPoint presentation has an extension _______________ or _______________.

B.	 State whether the following statements are True or False.

	 1.	 We can create, rename and delete files and folders.

	 2.	 We cannot create a duplicate copy of the selected file/folder at any desired location.

	 3.	 Search box in Windows 10 can be used to locate common file types.

	 4.	 Size option helps to arrange files in an alphabetical order by file name.

	 5.	 MS Excel spreadsheet has the extension .xls or .xlsx.

C.	 Define the following terms.
	 1.	 File
		 2.	 Copying

	 3.	 Search box

	 4.	 Sorting

	 5.	 File extension

D.	 Answer the following questions.

	 1.	 How will you move a file or folder?

	 2.	 Write the steps to move a file or folder from one drive like D: Drive to another like a pen drive.

	 3.	 How will you search a file or folder?

	 4.	 Write a note on wildcard characters.

	 5.	 Discuss the ways in which you can sort files.

	 6.	 Write the steps to sort files in the desired way.



Answers to Worksheet

A.	 1.	 folder	 2.	 Moving	 3.	 Item Type	 4.	 file format	 5.	 .ppt, .pptx
B.	 1.	 True	 2.	 False	 3.	 True	 4.	 False	 5.	 True
C.	 1.	 A file is a collection of information stored together on a computer under a particular name.
	 2.	 Copying a file/folder means creating a duplicate copy of the selected file/folder at any desired 

location.
	 3.	 Search box in Windows 10 is the most direct way to search a file or folder. It can be used to 

locate common file types.
	 4.	 Sorting the files on desktop refers to arranging them in a proper manner. The files can be 

sorted by name, size, item type and date on which they were modified. Sorting helps the user 
to back up files easily.

	 5.	 File extension is a part of a file name followed after dot (.). Some examples of file extensions 
are doc, pdf, jpeg and ppt. The file extensions tell us about the types of files. For example, doc 
file extension indicates that it is a Word file.

D.	 1.	 Follow the given steps to move or copy a file or folder.
•	 Double-click on the This PC icon on the desktop. You will see hard disk drives,
•	 CD/DVD drives, removable devices and network locations connected to your computer.
•	 Double-click on the D: drive icon. You will see all the files and folders stored in it.
•	 Select the file or folder to be moved or copied.
•	 Click on the Copy button in the ‘Clipboard’ group.
•	 Select the drive where the file needs to be moved or copied in the left pane.
•	 Click on the Paste button in the ‘Clipboard’ group.
•	 The file is moved or copied to the new location.

	 2.	 Follow the given steps to move a file or folder from one drive like D: Drive to another like a pen 
drive.
•	 Insert the pen drive into the computer.
•	 Right-click on the Start button and select the File Explorer option.
•	 Select D: drive from the ‘Navigation’ pane on the left.
•	 Select the file or folder to be moved to the pen drive from the right pane.
•	 Right-click on the file or folder and select the Cut or Copy option from the ‘Shortcut’ menu.
•	 Click on the pen drive icon from the left pane. The drive will open.
•	 Right-click on the blank area in the right pane and select the Paste option.
•	 The selected file or folder is moved from the D: drive of the computer to the pen drive.

	 3.	 Follow these steps to search a file or folder.
•	 Click on the Start button. You will find the ‘Search’ box located at the bottom of the left 

pane.
•	 Type either a part of the file or folder name or complete name. You can also type a word or 

phrase present in the file.
•	 The items that match the typed text will appear on the ‘Start’ menu.



	 4.	 Wildcard characters are special symbols such as an asterisk (*) and question mark (?) used to 
search a file or folder when the user does not know the exact name.
•	 The Wildcard character ‘*’ can be used to substitute a string of letters and symbols in its 

place. For example, A*.* will search all the file names starting with ‘A’ followed by any 
number of characters having any extension.

•	 The Wildcard character ‘?’ can be used to substitute for a single letter or symbol. For 
example, project?.docx will search all the file names starting with ‘Project’ followed by any 
one character and extension as .docx.

	 5.	 We can sort the files in the following ways.
•	 Name: This option helps to arrange files in an alphabetical order by file name.
•	 Size: This option arranges files in decreasing order of file size.
•	 Item Type: This option groups the files on the basis of their type.
•	 Date Modified: This option organises files according to the date on which they were last 

modified.
	 6.	 Follow these steps to sort the files in the desired way.

•	 Right-click on the blank area of the desktop.
•	 You will see a ‘Shortcut’ menu.
•	 Click on the Sort by option and select the desired sub-option.
•	 The icons will be arranged accordingly.



Chapter 3: Word Processor – Tabular Presentation

A.	 Fill in the blanks.

	 1.	 _______________ are vertical series of cells whereas _______________ are horizontal series 
of cells. 

	 2.	 We can use the _______________ to increase or decrease the size of a table manually. 

	 3.	 There are _______________ types of alignments to position a table in Word 2016. 

	 4.	 The spacing between the table and the page margins is called _______________. 

	 5.	 _______________ refers to the positioning of text in cells of a table. 

B.	 State whether the following statements are True or False.

	 1.	 A table is a grid made up of rows and columns. 

	 2.	 We can insert a predesigned table in a document using Forward Tables. 

	 3.	 We double-click on the word to select it. 

	 4.	 The process of dividing selected cell into separate cells is called splitting. 

	 5.	 Mailing refers to combining data split in numerous segments of a cell to give it a better look. 

C.	 Write the steps to perform the following tasks. 

	 1.	 Create a table using Table Grid. 

	 2.	 Create a table using a special drawing mode. 

	 3.	 Insert a quick table. 

	 4.	 Convert text to a table. 

	 5.	 Enter data in a table. 

D.	 Answer the following questions.

	 1.	 Write the steps to create a table using the Insert dialog box. 

	 2.	 How will you insert rows and columns in a table? 

	 3.	 Write the steps to delete rows and columns. 

	 4.	 Avni wants to change the row height in a table. How can she do that? 

	 5.	 How will you change the column width in a table? 

	 6.	 How will you split a cell in a table? 

	 7.	 Why do we apply border and shading effects to a table? Write the steps to apply borders and 
shading. 

	 8.	 How will you align a table? 



Answers to Worksheet

A.	 1.	 Columns, rows			   2.	 Table Resize Handle	 3.	 three 
	 4.	 indentation		   	 5.	 Text alignment 
B.	 1.	 True	 2.	 False 	 3.	 True 	 4.	 True 	 5.	 False 
C.	 1.	 Follow these steps to create a table using Table Grid.

•	 Click on the Table button in the ‘Tables’ group of the ‘Insert’ tab.

•	 You will see drop-down menu containing a grid.

•	 Drag the mouse pointer over the grid. Select the number of rows and columns to be 
inserted in the table.

•	 You will see the table inserted in the ‘working area’.
	 2.	 Follow these steps to create a table in your document using a special drawing mode.

•	 Click on the Table drop-down button on the ‘Insert’ tab.

•	 Select the Draw Table option. The mouse pointer will change to a Pencil pointer.

•	 Click on the desired position in the document and drag down the mouse pointer to the 
right to draw an outline of the table.

•	 Drag the Pencil pointer from the left to the right side of the table to draw a row.

•	 Drag the Pencil pointer from the top to the bottom of the table to draw a column.

•	 Click on the Draw Table button again or press the Esc key once you have completed 
drawing rows and columns of the table.

	 3.	 Follow these steps to insert a quick table.

•	 Click on the desired position you want to insert a table.

•	 Click on the Quick Tables option in the ‘Tables‘ group of the ‘Insert’ tab.

•	 Select the desired template from the drop-down list.
	 4.	 Word 2016 provides the feature of converting existing text to a table. Follow these steps to do 

so.

•	 Enter the text in the document.

•	 Select the text.

•	 Click on the Table button in the ‘Insert’ tab.

•	 Select the Convert Text to Table option from the drop-down menu.

•	 You will see the ‘Convert Text to Table’ dialog box.

•	 Specify the number of columns and rows in the ‘Number of columns’ and ‘Number of rows’ 
sections.

•	 Click on the OK button. The selected text will appear in the table form.
	 5.	 Follow these steps to enter data in a table.

•	 Place the cursor in a table cell where the data needs to be inserted.

•	 Press the Tab key or the Right arrow key to move to the adjacent cell.



•	 Press the Shift + Tab key or the Left arrow key to move to the previous cell. Enter the data 
in the table.

•	 Use the Up and Down arrow keys to shift the cursor to the cells above or below the current 
cell.

D.	 1.	 Follow these steps to create a table using the Insert dialog box.
•	 Click on the Table button in the ‘Insert’ tab. Select the Insert Table option from the drop-

down menu.
•	 You will see the ‘Insert Table’ dialog box.
•	 Specify the number of columns and rows. Click on the OK button. A table will be inserted in 

the working area as per the specified number of rows and columns.
	 2.	 We can add columns or rows in a table in between while working on it. New columns can be 

added to the right or left of any existing column and rows can be added above or below the 
selected row.

		  Follow these steps to inserts rows and columns.
•	 Select the column by clicking on its top border adjacent to which a new column needs to 

be inserted.
•	 You will see the ‘Table Tools’ tab on the Ribbon.
•	 Click on the Layout tab under it. Select either the Insert Left or Insert Right button in the 

‘Rows & Columns’ group.
•	 An ‘empty column’ gets inserted in the table.
•	 Similarly, select a row and then click either on the Insert Above or Insert Below button in 

the ‘Rows & Columns’ group of the ‘Layout’ tab. An ‘empty row’ gets inserted in the table.
	 3.	 Follow these steps to delete rows and columns.

•	 Select the row or column.
•	 Click on the Layout tab under the ‘Table Tools’ menu.
•	 Select the Delete button in the ‘Rows & Columns’ group. You will see a list of options.
•	 Select the Delete Rows or Delete Columns option in the drop-down menu.
•	 You can also right-click on the selected row/column to be deleted and then choose Delete 

Cells Delete entire row/Delete entire column option from the ‘Shortcut’ menu and then 
click on the OK button.

	 4.	 Avni can follow these steps to change row height in a table.
•	 Select the row whose height needs to be changed. 
•	 Right-click on the selected row. Select the Table Properties option from the ‘Shortcut’ menu.
•	 You will see the ‘Table Properties’ dialog box.
•	 Click on the Row tab.
•	 Select the Specify height checkbox.
•	 Specify the height either by typing or by clicking the spin arrows.
•	 Select one of the options from the Row height is list box.
•	 Click on the OK button.

	 5.	 Follow these steps to change the column width.
•	 Select the column whose width needs to be changed.
•	 Click on the Layout tab.



•	 Select the Properties button in the ‘Table’ group.
•	 You will see the ‘Table Properties’ dialog box.
•	 Click on the Column tab.
•	 Select the Preferred width checkbox.
•	 Increase or decrease the column width either by using the spin arrows or by typing in the 

specific values to set the width.
•	 Click on the OK button.

	 6.	 Follow these steps to split a cell.
•	 Select the cell to be split.
•	 Click on the Layout tab.
•	 Click on the Split Cells button in the ‘Merge’ group of the ‘Layout’ tab.
•	 You will see the ‘Split Cells’ dialog box.
•	 Specify the number of rows and columns in the ‘spin‘ boxes into which the selected cell 

needs to be split.
•	 Click on the OK button.
•	 The selected cell will be split.

	 7.	 We can enhance the overall appearance of a table by applying border and shading effects.
		  Follow these steps to apply borders and shading effects.

•	 Select the entire table.
•	 Click on the Design tab.
•	 Click on the Line Style and Line Width options in the ‘Borders’ group to change the line style 

and width.
•	 Click on the Borders dialog box launcher.
•	 You will see ‘Borders and Shading’ dialog box.
•	 Select the All option. Select the desired colour from the Colour drop-down menu. Similarly, 

you can select the desired setting for the border.
•	 Click on the Apply to text box and select the Table option from the drop-down list.
•	 Click on the Shading tab in the ‘Borders and Shading’ dialog box to apply colour effects to 

the table.
•	 Click on the drop-down arrow under the ‘Fill’ section. You will see the Colour Palette.
•	 Select any shade and click on the OK button.
•	 Observe the changes in the table.

	 8.	 Follow these steps to align a table.
•	 Select the entire table using the Table Move Handle at the top left corner of the table. 
•	 Select the Layout tab under the ‘Table Tools’ tab.
•	 Click on the Properties option in the ‘Table’ group.
•	 You will see ‘Table Properties’ dialog box.
•	 You can also right-click on the table and select the Table Properties option from the 

‘Context’ menu.
•	 Select the Table tab and choose the desired alignment option in the ‘Alignment’ section.
•	 The selected alignment will be applied to the table.



Chapter 4: Word Processor—Mail Merge

A.	 Fill in the blanks.
	 1.	 _______________ contains the required filed names for carrying out the merge process.

	 2.	 _______________ is also called the Data File.

	 3.	 The Data File has a table containing _______________ for each field of information.

	 4.	 The _______________ is the first row of the table.

	 5.	 Finish & Merge button is found in the _______________ group on the _______________ tab.

B.	 State whether the following statements are True or False.

	 1.	 Main Document stores information to be brought into the Data Source.

	 2.	 Mail Merge reads the data source and physically merges it with the Main Document to 
generate letters for all the records found in the Data Source.

	 3.	 The resultant document of Mail Merge operation contains copies of the Main Document 
along with the information stored in the data file.

	 4.	 We click on Add Columns button to add or remove fields.

	 5.	 Insert Merge Field button is found in the Write & Insert Fields group of the Mailing tab.

C.	 Answer the following questions.

	 1.	 Describe the main Mail Merge documents.

	 2.	 List the three main steps involved in the process of Mail Merge.

	 3.	 Write the steps to create a Mail Merge Document.

	 4.	 How will you create a recipient list?

	 5.	 Write the steps to insert merge fields.

	 6.	 How will you view the merged data in Mail Merge?

	 7.	 Write the steps to take out the printouts of your data with the merged data of source.



Answers to Worksheet

A.	 1.	 Main Document		 2.	 Data Source			   3.	 columns
	 4.	 header row			   5.	 Finish, Mailings
B.	 1.	 False	 2.	 True	 3.	 True	 4.	 False	 5.	 True
C.	 1.	 Let’s learn about the main Mail Merge documents.

•	 Main Document: The body of the standard letter to be sent to all recipients is called the 
Main Document. It also contains the required field names for carrying out the merge 
process.

•	 Data Source: Data Source stores information to be brought into the Main Document. It is 
also called the Data File.

•	 Merge Field: The Data File has a table containing columns for each field of information. 
For example, it may store names of people, their addresses and similar information. It has 
some variable data such as the first name, the last name of a recipient and the postal pin 
code of the place he/she belongs to. The header row is the first row of the table. It records 
collection of variable data regarding a person or a thing.

	 2.	 The process of Mail Merge involves three main steps.

•	 Creating the Main Document containing the body of the letter

•	 Creating the Data Source that contains the records of recipients

•	 Merging the Data Source and the Main Document
	 3.	 Follow these steps to create Main Document.

•	 Create a new document and type a letter. You can also open an existing letter in ‘Microsoft 
Word’ that needs be sent to different people at their addresses.

•	 Click on the Mailings tab.

•	 Click on the Start Mail Merge drop-down arrow in the ‘Start Mail Merge’ group.

•	 Select the Step-by-Step Mail Merge Wizard option.

•	 You will see the ‘Mail Merge’ task pane on the right side of the application window.

•	 Select the Letters radio button under the ‘Select document type’ section.

•	 Click on the Next: Starting document (wizard step) under ‘Step 1 of 6’ section at the bottom 
of the task pane.

•	 Select the type of set up for your letters.

•	 Click on the Use the current document radio button under the ‘Select starting document’ 
section.

•	 Click on the Next: Select recipients under ‘Step 2 of 6’ section.
	 4.	 Follow these steps to create a recipient list.

•	 Select the Type a new list radio button under ‘Select recipients’ section in the ‘Mail Merge’ 
task pane.

•	 Click on the Create option.

•	 You will see the ‘New Address List’ dialog box.



•	 Click on the Customize Columns button to add or remove fields.

•	 Enter data in the respective fields and click on the New Entry button.

•	 Enter six records of your friends. Click on the OK button.

•	 You will see the ‘Save Address List’ dialog box.

•	 Specify a name in the ‘File name’ box and click on the Save button. You will see the ‘Mail 
Merge Recipients’ dialog box displaying the details of all the records added by you.

•	 Select the Data Source and click on the Edit button located under the ‘Data Source’ box to 
make changes in details.

•	 You will see tick marks placed on the check boxes next to the ‘Data Source ’field by default. 
These indicate that the records are selected.

•	 You can deselect a particular address by clicking on that specific check box if you do not 
want the letter to be sent to that address.

•	 Click on the OK button.

•	 Click on the Next: Write your letter (wizard step) under ‘Step 3of 6’ section in the ‘Mail 
Merge’ task pane.

	 5.	 Follow these steps to insert merge fields.

•	 Place the cursor at the position where the record fields need to be inserted.

•	 Click on the Insert Merge Field button in the ‘Write & Insert Fields’ group on the ‘Mailing’ 
tab.

•	 You will see the drop-down menu displaying a list of field names create by you.

•	 Click on the field name that needs to be added. Similarly, insert other fields into the 
document.

•	 You will notice the names of selected field appearing in your document one after another, 
horizontally.

•	 Separate the field names by pressing the Enter key.
	 6.	 We can view the data source on the screen to check whether Microsoft Word has picked it up 

as per the merged fields or not.
		  Follow these steps to view the merged data.

•	 Click on the Preview Results button in the ‘Preview Results’ group on the ‘Mailings’ tab. 
You can also click on the Next: Preview your letters (wizard step) option under ‘Step 4 of 6’ 
section.

•	 You will see first record. Click on the Next Record button in the ‘Preview Results’ group to 
view the next record of the data source.

	 7.	 Follow these steps to take out the printouts of your letter with the merged data of source.

•	 Click on the Finish & Merge button in the ‘Finish’ group on the ‘Mailings’ tab.

•	 Select the Print Documents option from the drop-down menu. You can also click on the 
Next: Complete the merge (wizard step) under ‘Step 5 of 6’ section in the task pane and 
then click on the Print option under ‘Merge’ section.

•	 You will see the ‘Merge to Printer’ dialog box.

•	 Specify the desired print setting and click on the OK button.

•	 The selected records will be printed separately along with the letter.


